Wiskunde omzetting formule uit Javascript naar Excel

Wiskunde is niet alleen een vak op school. Kom je ergens in de praktijk (bijvoorbeeld tijdens je werk) een wiskundig probleem tegen dan kun je hier om hulp vragen.
Plaats reactie
NumNum
Nieuw lid
Nieuw lid
Berichten: 5
Lid geworden op: 27 feb 2018, 18:58

Wiskunde omzetting formule uit Javascript naar Excel

Bericht door NumNum » 11 jun 2018, 07:30

Geachte,

Kan er iemand mij helpen om volgende formule uit Javascript om te zetten in een Excel gebaseerde?

=Math.round(Math.exp(-3.2328+2.2475*Math.log(KV100)-0.07813*T-0.02829*T*Math.log(KV100))*100)/100

Ik dacht toch te herkennen dat het hier om een LOG met grondtal 10 gaat en MACHT met grondtal 2...of ben ik fout?

Bedankt, mvg

arie
Moderator
Moderator
Berichten: 3046
Lid geworden op: 09 mei 2008, 09:19

Re: Wiskunde omzetting formule uit Javascript naar Excel

Bericht door arie » 11 jun 2018, 08:46

In Java zijn het grondtal van exp() en log() gelijk aan e = 2.71828... = het grondtal van de natuurlijke logaritme (vergelijkbaar met de toetsen e^x en ln op een standaard rekenmachine).

Als je in Excel:
- in cel A1 de waarde van je KV100 plaatst, en
- in cel A2 de waarde van T,
dan kan je in elke andere cel je formule plaatsen:

= ROUND( EXP(-3.2328 + 2.2475*LN($A$1) - 0.07813*$A$2 - 0.02829*$A$2*LN($A$1)); 2)

EXP() en LN() werken als in Java exp() en log()
ROUND(x;n) rondt het getal x af in n decimalen.
Als je de Nederlandse versie van Excel hebt is dit de functie AFRONDEN(x;n)
(Noot: in je Java formule vermenigvuldig je je resultaat met 100, rond dan af naar een geheel getal, en deel je dat vervolgens door 100, wat neerkomt op afronden op n=2 cijfers achter de komma.)

Afhankelijk van je toetsenbordinstellingen moet je de symbolen punt, komma en puntkomma mogelijk nog aanpassen.

Voorbeeld:
Met:
KV100 = 222
T = 11
levert je formule:
583.49

NumNum
Nieuw lid
Nieuw lid
Berichten: 5
Lid geworden op: 27 feb 2018, 18:58

Re: Wiskunde omzetting formule uit Javascript naar Excel

Bericht door NumNum » 12 jun 2018, 19:09

Dag Arie,

Wederom bedankt om dit probleem op te lossen! De formule werkt inderdaad goed, maar ik had graag wel een kleine aanpassing willen voorstellen, nl.

= ROUND( EXP(2,71828;(-3.2328 + 2.2475*LN($A$1) - 0.07813*$A$2 - 0.02829*$A$2*LN($A$1))); 2)

Je moet wel degelijk het grondtal in de formulle vermelden, allesins toch in de nederlandse excel.

Wordt dus:

=AFRONDEN(MACHT(2,71828;(-3,2328+(2,2475*LN(E25))-(0,07813*E27)-(0,02829*E27*LN(E25))));2)

mvg

arie
Moderator
Moderator
Berichten: 3046
Lid geworden op: 09 mei 2008, 09:19

Re: Wiskunde omzetting formule uit Javascript naar Excel

Bericht door arie » 12 jun 2018, 21:00

Vreemd...
De Engelse versie kent deze 2 functies:
EXP(x) = e^x
POWER(x;y) = x^y
Voorbeeld:
EXP(1) = e^1 = 2.71828...
POWER(2;3) = 2^3 = 8

De Nederlandse MACHT(x;y) lijkt een vertaling van POWER(x;y)

Weet je zeker dat er ook niet een Nederlandse versie van de functie EXP(x) is?

PS:
Volgens
https://www.martijn-lammerts.com/site/v ... ederlands/
zou dit dezelfde functie EXP(x) moeten zijn.

Plaats reactie